Get in touch
Back
Resolved

Inviting students and joining a class currently unavailable

Started 3 Mar at 06:17am GMT, resolved 5 Mar at 02:20pm GMT.

Digital Platforms (Ultimate Dialogue Adventure & Teacher Portal)
Resolved

The issue is now resolved and the functionality has been restored.

Posted 5 Mar at 02:20pm GMT.
Created

We are working to restore these functionality promptly.

Posted 3 Mar at 06:17am GMT.