Get in touch
Back
Resolved

Student dashboard currently unavailable

Started , resolved .

Digital Platforms (Ultimate Dialogue Adventure & Teacher Portal)
Resolved

Issue was fixed.

Posted .
Created

We are aware of a technical issue where students are receiving an error when attempting to reach the dashboard. We are working on a fix.

Posted .