Get in touch
Back
Maintenance

Scheduled release

Completed 5 Apr at 10:10am BST.

Digital Platforms (Ultimate Dialogue Adventure & Teacher Portal)
Completed

Maintenance completed

Posted 5 Apr at 10:10am BST.
Started

A release is scheduled to go live on 5 April 2022 at 09:00 UTC. The release should be completed a 09:10 UTC. Users might experience some down time during the release.

Posted 5 Apr at 10:00am BST.