Get in touch
Back
Resolved

Site and platforms unavailable due to upstream provider issues

Started 18 Nov at 11:48am GMT, resolved 18 Nov at 01:08pm GMT.

Digital Platforms (Ultimate Dialogue Adventure & Teacher Portal) Generation Global Mobile App Generation Global (public site)
Resolved

Cloudflare infrastructure has started to recover and our site and platforms are coming back up.

Posted 18 Nov at 01:08pm GMT.
Created

The public site and platforms were reporting widespread 500 errors due to an infrastructure issue with our provider Cloudflare. Details of their incident: https://www.cloudflarestatus.com/incidents/8gmgl950y3h7

Posted 18 Nov at 11:48am GMT.