Back
Maintenance

Scheduled release
Completed .
Digital Platforms (Ultimate Dialogue Adventure & Teacher Portal)
Generation Global Mobile App
Completed
Maintenance completed
Posted
.

Started
- Upgrade of Content Management System to Drupal 11
This requires also updating some database tables and will result in a short downtime.
Posted
.