Get in touch
Back
Maintenance

Scheduled release

Completed 7 Aug at 10:35am BST.

Digital Platforms (Ultimate Dialogue Adventure & Teacher Portal)
Completed

Maintenance completed

Posted 7 Aug at 10:35am BST.
Started

GG-1071 [v2] Teachers should not receive encouragement email when reviewing a student topic

GG-1043 PHP error when Signing in with Apple

Posted 7 Aug at 10:30am BST.