Get in touch
Back
Maintenance

Scheduled release

Completed 25 Feb at 09:36am GMT.

Digital Platforms (Ultimate Dialogue Adventure & Teacher Portal)
Completed

Maintenance completed

Posted 25 Feb at 09:36am GMT.
Started

GG-1006: Regression bug: alumni unable to open comments/dialogues

Posted 25 Feb at 09:27am GMT.