Get in touch
Back
Maintenance

Scheduled Maintenance

Completed 26 Jul at 06:00pm BST.

Digital Platforms (Ultimate Dialogue Adventure & Teacher Portal)
Completed

Maintenance completed

Posted 26 Jul at 06:00pm BST.
Started

Scheduled maintenance lasting approx. 108 minutes for the release of content moderation upgrades and new API endpoints.
The Ultimate Dialogue Adventure and the Teacher Portal will remain offline during the maintenance.

Posted 26 Jul at 04:00pm BST.