Get in touch
Back
Maintenance

Scheduled release

Completed 7 Mar at 02:10pm GMT.

Digital Platforms (Ultimate Dialogue Adventure & Teacher Portal)
Completed

Maintenance completed

Posted 7 Mar at 02:10pm GMT.
Started

GG-533: New field for video conference no-show participants
GG-712: Don't show the XP popup when 0 XP is awarded
GG-713: Dialogue preference popup fix
GG-687: Login IP history

Posted 7 Mar at 02:00pm GMT.