Get in touch
Back
Maintenance

Scheduled release

Completed 19 Jan at 11:05am GMT.

Digital Platforms (Ultimate Dialogue Adventure & Teacher Portal)
Completed

Maintenance completed

Posted 19 Jan at 11:05am GMT.
Started

GG-539 Add question to teacher registration page
GG-691 Basic auth (and redirects)

Posted 19 Jan at 11:00am GMT.