Get in touch
Back
Maintenance

New educators' dashboard release

Completed 12 Dec at 11:45am GMT.

Digital Platforms (Ultimate Dialogue Adventure & Teacher Portal)
Completed

Posted 12 Dec at 11:45am GMT.
Started

Release will include a new onboarding tutorial and a new dashboard for educators

Posted 12 Dec at 11:30am GMT.