Get in touch
Back
Maintenance

Scheduled release

Completed 15 Nov at 12:05pm GMT.

Digital Platforms (Ultimate Dialogue Adventure & Teacher Portal)
Completed

Maintenance completed

Posted 15 Nov at 12:05pm GMT.
Started

GG-688 Change recipient of safeguarding report form
GG-374 Update username when email is updated and require email verification
GG- 684 Popups for old post-video conference reflections reappear if a step is added
GG-680 Alumni unable to open dialogue spaces

Posted 15 Nov at 12:00pm GMT.